Help us out by shopping Amazon.com

Search:
Keywords:

General Comments

Here is where you can leave comments about this site, boats, motors, fishing, and other topics, or just simply say hello and tell us where you are from.  Please, no political, jokes, or anything not appropriate for this site. You must Login if you wish to leave comments.

 

Image removed.

You can now login with your Facebook account.

 

Comments

Permalink

Comment

So I got a 1952 evinrude lightwin that I've been trying to get started. I've changed gear oil, cleaned fuel tank, cleaned the spark plugs, taken the carb off, then took off the bowl and sprayed the crap out of the whole carb with carb cleaner, and took the bottom assembly off and cleaned the shaft and the water pump. I got it all back together and it has fuel flow. I crank it with a drill and all it does is pop every once and a while but it just doesn't start. I have spark so it's not an electrical issue. I just cant get it started. Being only 15 I dont have the most experience so if you all could point me in the right direction I'd be grateful. Thanks

 

Comment

I mean that in a helpful way.  Everything does have to be right and there are no shortcuts.  I am still learning that truth.

Hopefully you read through my 3.5 HP ignition Tune-Up-procedure.  Also the 5.5 is the same ignition but both should be read to get the full benefit.

Tell me about the coils, points, condensers, and plug wires.  It is well worth the expense to replace all of those parts because they do go bad simply because of age.

Also timing is important.  It must be right.  Don’ give up.  You will get there.

Comment

I have a 1955 QD 16 also and from what I read is the lower unit seals are the same as a same year 18 hp as the lower units changed in 1958 on the 10 hp were the 18 hp should have the same seals as the older 10 s.

 

 

Permalink

Comment

Try swapping the plug wires top to bottom. If they were backwards and everything else was right you would get an occasional pop, bang, or backfire as you describe. I had this same issue when I was new to working on 2cyl outboards.

I am also 15 but have been around outboards for a while now. This is my experience and there are definitely people out there with more, it’s just my 2 cents 

Permalink

Comment

what is the proper compression for a 1977 Johnson 25hp  model no 25R77H, and is there a right way and wrong way to read this number on the tester as in how may times do i cycle each cylinder?

Permalink

Comment

I have a 1977 Johnson 25 hp model# 25R77H and I need to know what is a good compression per each cylinder. Also if anyone could tell me what besides the starter do i need to convert from pull start to elec start ie modifications parts to add to do this. Thanks for any help i can get. Im trying to restore boat for our churches use at the kids summer camp, its needed a new floor, The boat is a 1970 Starcraft 14' mariner deep v. so far so good should have floor back in by end of next week and then start in on the motor. Once again thanks again for any info.

 

Minister Brian

Permalink

Comment

Hello, I have recently been buying up these johnson seahorse 10hps because I and fascinated with them and I have been trying for ever to find a seal kit  or part numbers for the seals on my johnsons lower unit. I have bought several seals online and they are always wrong.There are two seals that I have part numbers for and a spaghetti seal and a 2 o rings (one for the shift shaft and one for the prop sleeve with the bearing in it). And is there a part number for the brass bushing that holds the shift o ring? Someone must know and be able to point me in the right direction. Any help is greatly appreciated. And feel free to email me bores.keith@yahoo.com 

P.s. I love what this site is doing. More parts would be a plus.

Permalink

Comment

I have an Evinrude Fisherman 5.5, model 5523. Rebuilt the carburetor before last season. Ran pretty well throughout the summer, but towards the end started having the same problem I thought I fixed. When motoring to the dock the engine will start to bog down and stall, unless I pull the choke partially closed. Idles OK, but needs the choke partially closed to run at higher throttle. Suggestions?

.

.

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer